TA的每日心情 | 擦汗 昨天 09:02 |
---|
签到天数: 1046 天 连续签到: 4 天 [LV.10]测试总司令
|
1测试积点
案例配置拓扑:
案例配置需求
1、 在五台路由器之间运行OSPF协议,发布直连网段和环回口;
2、 在R4上配置接口S1/4只能接收IP优先级5和6的数据包;
3、 在R5上配置接口S1/5只能接收IP优先级6的数据包;
4、 在R1上使用扩展ping,TOS为64,要求可以ping通R4;
5、 在R2上使用扩展ping,TOS为128,要求可以ping通R5;
案例配置思路
1.根据拓扑配置IP地址
- R1:
- interface Loopback0
- ip address 1.1.1.1 255.255.255.0
- ip ospf network point-to-point
- interface Serial1/1
- ip address 13.1.1.1 255.255.255.0
- serial restart-delay 0
- R2:
- interface Loopback0
- ip address 2.2.2.2 255.255.255.0
- ip ospf network point-to-point
- interface Serial1/2
- ip address 23.1.1.1 255.255.255.0
-
- R3:
- interface Loopback0
- ip address 3.3.3.3 255.255.255.0
- interface Serial1/1
- ip address 13.1.1.2 255.255.255.0
- interface Serial1/2
- ip address 23.1.1.2 255.255.255.0
- interface Serial1/4
- ip address 34.1.1.2 255.255.255.0
- interface Serial1/5
- ip address 35.1.1.2 255.255.255.0
-
- R4:
- interface Loopback0
- ip address 4.4.4.4 255.255.255.0
- ip ospf network point-to-point
- interface Serial1/4
- ip address 34.1.1.1 255.255.255.0
- R5:
- interface Loopback0
- ip address 5.5.5.5 255.255.255.0
- ip ospf network point-to-point
- interface Serial1/5
- ip address 35.1.1.1 255.255.255.0
复制代码 3.在R4的接口上配置数据过滤:
- access-list 100 permit ip any any precedence critical /只接收IP优先级5的数据/
- access-list 100 permit ip any any precedence internet /只接收IP优先级6的数据/
- interface serial 1/4
- ip access-group 100 in /接口下调用ACL/
复制代码 4.在R5的接口上配置数据过滤:
- access-list 100 permit ip any any precedence internet
- interface serial 1/5
- ip access-group 100 in
复制代码 5.在R3上配置MQC,转换数据优先级:
- access-list 100 permit ip host 1.1.1.1 host 4.4.4.4 precedence immediate
- /匹配从1.1.1.1发往4.4.4.4且优先级为2的数据/
- access-list 101 permit ip host 2.2.2.2 host 5.5.5.5 precedence flash-override
- /匹配从2.2.2.2发往5.5.5.5且优先级为4的数据/
- class-map match-all pre4 /创建类图pre4/
- match access-group 101 /调用ACL 101/
- class-map match-all pre2
- match access-group 100
- !
- !
- policy-map MQC /创建策略映射图MQC/
- class pre2 /调用类图pre2/
- set precedence 5 /设置IP优先级为5/
- class pre4
- set precedence 6
复制代码 案例检验结果
1、 配置完成后,用1.1.1.1去ping 4.4.4.4:
2、 配置完成后,在R1上用1.1.1.1扩展ping的TOS 64去ping 4.4.4.4
案例总结及其它
1、 MQC是模块化QOS配置命令集,由匹配流量、设置流量、调用策略三个部分组成;
2、 使用ACL配合class-map来匹配流量;
3、 使用policy-map调用class-map来设置流量;
4、 MQC可以在接口下、子接口、控制模版下调用;
5、 数据包的优先级可以用TOS、DSCP、IP优先级三种方式来定义,他们之间可以互相转换;
6、 TOS=DSCP8=IP64;
|
|